Author Topic: Weathercat not showing usb connection option  (Read 169 times)

manitario

  • Calm
  • *
  • Posts: 5
  • Station Details: Davis Vantage Vue with Davis datalogger, Macbook IOS Mojave.
Weathercat not showing usb connection option
« on: October 01, 2019, 06:28:39 PM »
Hi, I have a Davis Vantage Vue with the Davis datalogger. Have been using this setup for the last 6 years; every month or so I download the data onto the computer via a USB connection. This month I went to do the same; plugged in the USB and opened Weathercat and found that the USB option on the drop down comm port was gone ie. the /dev/cu.SLAB_USBtoUART option was no longer there. I tried re-installing the Silicon Labs driver (and authorized it through security preferences) and still don't have the option to connect. Using Mojave on a 2019 Macbook pro. Thoughts???

manitario

  • Calm
  • *
  • Posts: 5
  • Station Details: Davis Vantage Vue with Davis datalogger, Macbook IOS Mojave.
Re: Weathercat not showing usb connection option
« Reply #1 on: October 01, 2019, 06:34:12 PM »
Troubleshooting my own problem here; in system report the SiLabsUSB Driver is listed as installed but not loaded. I assume that somehow it needs to be loaded for it to work? I did authorize it in the security preferences when I initially installed it.

Blicj11

  • Storm
  • *****
  • Posts: 3266
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Mojave | Sharx SCNC2900 Webcam | Supportive Wife
Re: Weathercat not showing usb connection option
« Reply #2 on: October 01, 2019, 07:39:56 PM »
I assume this is the version of the driver you are using?

CP210x Macintosh OSX VCP Driver 5.2.1    - September 9, 2019
Blick


manitario

  • Calm
  • *
  • Posts: 5
  • Station Details: Davis Vantage Vue with Davis datalogger, Macbook IOS Mojave.
Re: Weathercat not showing usb connection option
« Reply #3 on: October 01, 2019, 10:08:38 PM »
Yes, that's it.

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 5332
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, Mac mini (2018), macOS 10.14.3, WeatherCat 3
Try reinstalling driver. (Re: Not showing usb connection option)
« Reply #4 on: October 01, 2019, 11:36:22 PM »
Dear manitario, Blick, and WeatherCat troubleshooters,

Troubleshooting my own problem here; in system report the SiLabsUSB Driver is listed as installed but not loaded. I assume that somehow it needs to be loaded for it to work? I did authorize it in the security preferences when I initially installed it.

Try removing all drivers (in case there are more than one,) reinstalling the latest driver, and authorizing once more the driver in the security pane of the system preferences.  I vaguely recall having a similar problem where Apple "claimed" I had authorized it but in fact the system didn't accept the authorization.

Let us know if that does the trick for you.

Cheers, Edouard  [cheers1]

manitario

  • Calm
  • *
  • Posts: 5
  • Station Details: Davis Vantage Vue with Davis datalogger, Macbook IOS Mojave.
Re: Weathercat not showing usb connection option
« Reply #5 on: October 02, 2019, 10:55:50 PM »
Still won't show up as a connection after uninstalling/re-installing the driver. Any other suggestions?

xairbusdriver

  • Storm
  • *****
  • Posts: 2362
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: Weathercat not showing usb connection option
« Reply #6 on: October 03, 2019, 01:02:44 AM »
Make sure you Shutdown/Restart after reinstalling the driver. The OS only runs those on Startup, it usually won’t ‘see’ that you installed one or even deleted one until then.

manitario

  • Calm
  • *
  • Posts: 5
  • Station Details: Davis Vantage Vue with Davis datalogger, Macbook IOS Mojave.
Re: Weathercat not showing usb connection option
« Reply #7 on: October 03, 2019, 05:38:41 PM »
Yep, it shows that the driver is present, just doesn't show up as a connection option in the WeatherCat connection dropdown menu. Kind of sounds like I'm out of luck at this point for using this software?

Randall75

  • Storm
  • *****
  • Posts: 1250
  • CWOP-CW6734 WeatherUnderground-KOHNEWAR6
    • CW6734
    • KOHNEWAR6
    • Randy's Weather On The Hill
  • Station Details: Davis Vantage Pro 2 Plus.iMac i5 OS High Sierra 10.13.6 8GB Ram, WeatherCat 3,Logitech 9000 Pro Web Cam
Re: Weathercat not showing usb connection option
« Reply #8 on: October 03, 2019, 08:02:54 PM »
Did you also quit WeatherCat then restart your computer and then restart WeatherCat?

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 5332
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, Mac mini (2018), macOS 10.14.3, WeatherCat 3
More things to try. (Re: Weathercat not showing usb connection option)
« Reply #9 on: October 04, 2019, 11:18:05 PM »
Dear manitario and WeatherCat troubleshooters,

Sorry you are having so much trouble with this.  Honestly, I thought this couldn't go wrong, but obviously that was optimism on my part.  Scratching my head I have a few more suggestions - if far fetched.

  • Try running Disk First Aid or preferably TechTool Pro on your system hard drive to make sure there is no file system corruption.  These settings need to be stored somewhere on the hard drive, perhaps the problem is storing the authorization.
  • After step-1, uninstall and reinstall and authorize the driver once more.  However, this time open the Console application and look for any messages that might appear there.  Perhaps an error will be logged that will help you diagnose the problem.

Beyond that you might have to search for help beyond our forum.  Since this is an issue that any Davis user might encounter, you might try WXForum:

http://www.wxforum.net/

Another potential resource would be Apple's own support community:

https://discussions.apple.com/welcome

As the ultimate stretch, you might try contacting Silicon Labs directly to see if they might help you.  Here is the contact page:

https://www.silabs.com/about-us/contact-us

Please do let us know if and how you resolve this so we can help the next person with this sort of problem.

Cheers, Edouard