Author Topic: WeatherCat failing to use 2 Logitech USB webcams (???)  (Read 48 times)

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 5061
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011), macOS 10.13.6, WeatherCat 3
WeatherCat failing to use 2 Logitech USB webcams (???)
« on: January 01, 2019, 10:33:41 PM »
Dear WeatherCat troubleshooters,

Alas, this time I'm the one with the trouble and I'm utterly at wits end trying to solve this problem.  A little over 2 weeks ago, WeatherCat stopped working with my venerable Logitech webcam.  Assuming that it had simply broken, I sought some advice on what to replace it with on this thread:

http://athena.trixology.com/index.php?topic=2895.0

Based on Randall's advice, I decided to buy another Logitech webcam.  Alas, when I plugged it in and launched WeatherCat - it crashed!  Here is the punch-line and the crash report is attached.

Code: [Select]
Application Specific Information:
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: 'The activeVideoMinFrameDuration passed is not supported by the device.  Use -activeFormat.videoSupportedFrameRateRanges to discover valid ranges.'
terminating with uncaught exception of type NSException
abort() called

Worse still, the crash occurred after the watchdog application was launched.  As a result, WeatherCat tried starting over and over!  I had to kill the Python watchdog process to regain control of my computer.

Any attempt to get WeatherCat to launch caused the same crash even after I removed the new webcam.  Eventually, I got the strange idea of putting back the old webcam.  This allowed WeatherCat to run normally after it more once it detected the "dead webcam."

However, this is where da' plot really thickens.  I had not checked the old webcam - I just trusted the WeatherCat pronouncement.  After all this I needed to understand if any of these webcams were working.  So I fired up Quicktime and . . . . . both webcam are working just fine!  ???  Quicktime has no problems displaying an image with the old webcam.

My computer was having some problems with RAM.  I had to replace it over the Christmas weekend.  I checked and the new memory isn't malfunctioning.  I have also zapped the PRAM and replaced my preference files for WeatherCat with my backup.  No improvement.

Does anybody have some ideas of what else I could try to get my webcam back on line?

Sign me definitely at wits end!
  Edouard  ???