Author Topic: My PWS not receiving WeatherCat FTP Data.  (Read 692 times)

N4KHQ

  • Gentle Breeze
  • **
  • Posts: 92
    • KGADAHLO8
  • Station Details: iMac, Davis Vonage Pro
My PWS not receiving WeatherCat FTP Data.
« on: February 13, 2018, 12:42:26 PM »
Are you guys seeing a similar problem? About every 24 hours I notice the weather station getting behind. If I restart WeatherCat the PWS start showing the current data. If I don't catch the missing uploads in a few hours, the PWS drops off and tells me how many hours since last update. Restarting  WeatherCat has always fixed the PWS. When the PWS is working, WeatherCat has been saying 100% acknowledgment and Current Status is Running. If data is not uploading, acknowledgments are less than 100% and Current Status is Starting. I am wondering  why restarting WeatherCat always fixes the problem. Thanks

Blicj11

  • Storm
  • *****
  • Posts: 2971
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS High Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: My PWS not receiving WeatherCat FTP Data.
« Reply #1 on: February 13, 2018, 03:14:04 PM »
Could you please tell us what version of WeatherCat you are running, which data logger you are using, and clarify what you mean by PWS? Are you referring to uploading data to Weather Underground or are you referring to pwsweather.com?
Blick


elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4929
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011), macOS 10.13.6, WeatherCat 3
No data sent to WU via FTP (Re: My PWS not receiving WeatherCat FTP Data.)
« Reply #2 on: February 13, 2018, 11:16:15 PM »
Dear N4KHQ, Blick, and WeatherCat troubleshooters,

Are you guys seeing a similar problem? About every 24 hours I notice the weather station getting behind. If I restart WeatherCat the PWS start showing the current data. If I don't catch the missing uploads in a few hours, the PWS drops off and tells me how many hours since last update. Restarting  WeatherCat has always fixed the PWS. When the PWS is working, WeatherCat has been saying 100% acknowledgment and Current Status is Running. If data is not uploading, acknowledgments are less than 100% and Current Status is Starting. I am wondering  why restarting WeatherCat always fixes the problem. Thanks

Judging from your previous posts, what you call "PWS" is your station on Weather Underground.  I just checked my station on Weather Underground and everything is current.  However, Weather Underground has been suffering from the migration on the Amazon cloud environment and they may still be having some issues.

The only thing that sent to Weather Underground via FTP is your webcam image.  Weather data is sent via HTTP string.  I don't know why restarting appears to get Weather Underground working again.  Perhaps it isn't the restart itself, but simply the pause in data upload.  Since it takes time to quit and start WeatherCat, that might be enough time for the servers in question to catch up on their processing and display current data.

If the only problem you are experiencing is with Weather Underground, probably the only viable cure is to wait and hope that the problems will be all ironed out on the Weather Underground end of things.  Only if this continues for another week or more might it be worth double-checking that all is working with your WeatherCat installation.

Cheers, Edouard

Felix

  • Gale
  • ****
  • Posts: 392
  • Station Details: Davis Wireless Vantage Pro-2 Plus with FARS, Leaf & Soil Moisture/Temp Sta + WeatherLink IP. Two prototype Sharx 3905 HD wide-angle webcams and one production model 3905, all using EvoCam v5.0. WeatherCat 3.02, macOS 10.14.1 B3 Build 18B57c (Mojave).
Re: My PWS not receiving WeatherCat FTP Data.
« Reply #3 on: February 14, 2018, 10:40:48 AM »
Someone else here on the forum already posted the Trello WeatherUnderground board which is tracking updates but here it is again:


http://trello.com/b/hqC0tb0u/weather-underground


Looks like the webcam problems are pretty much solved with a doubling of server capacity. And I think the rapidfire complaints have been put to bed. Just click on each card to read the posts pertaining to that subject. There's been a bunch about webcams.

N4KHQ

  • Gentle Breeze
  • **
  • Posts: 92
    • KGADAHLO8
  • Station Details: iMac, Davis Vonage Pro
Re: My PWS not receiving WeatherCat FTP Data.
« Reply #4 on: February 15, 2018, 11:37:27 AM »
Sorry for the incomplete post and missing information. I'm running the latest released version 2.4.4, have not tried 3 beta. Should I try the beta, I only use WeatherCat to upload to my personal weather station on weather underground. I switched to Rapid Fire on a suggestion from Ben or Sean on the https://trello.com/b/hqC0tb0u/weather-underground board. PWS is Personal Weather Station. Yes FTP is incorrect. I FTP a jpeg image from a D-link DCS-7010L webcam which has a built in web interface that allows FTP timed uploads directly.

I have been up on my Weather Underground Personal Weather Station for 48 hours which ties a record for me since the weather underground server outage.  I was thinking someone might give me some insight into WeatherCat's html string upload. I was just wonder why Weather Underground Server problems always gets repaired with a restart of  WeatherCat and if anyone on WeatherCat(WC) integration had noticed the same problem. WeatherCat must be doing something special in the startup process to repair the data feed to Weather Underground. I have restarted WC at least 25 times when I had a data outage ranging for 10 minutes to 9 hours and in every case, WU-PWS started updating. Something must be hanging WC in status = starting and it takes a restart to get current status running. When WC says status is starting and sending data that my PWS is not showing as being received, I have noticed WC start uploading Historical in the WC log.

Thanks for all the replies

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4929
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011), macOS 10.13.6, WeatherCat 3
Not aware of anything. (Re: My PWS not receiving WeatherCat FTP Data.)
« Reply #5 on: February 16, 2018, 12:20:34 AM »
Dear N4KHQ and WeatherCat troubleshooters,

. . . . .
WeatherCat must be doing something special in the startup process to repair the data feed to Weather Underground. I have restarted WC at least 25 times when I had a data outage ranging for 10 minutes to 9 hours and in every case, WU-PWS started updating. Something must be hanging WC in status = starting and it takes a restart to get current status running. When WC says status is starting and sending data that my PWS is not showing as being received, I have noticed WC start uploading Historical in the WC log.

You might need to ask Stuart Ball (WeatherCat developer) about it, but I'm not aware of anything that WeatherCat does upon restarted that could "repair" anything.  The only thing WeatherCat will do upon a restart is try to upload all data that hadn't be uploaded in a historical mode.  It could be the state of Weather Underground servers were such that they would accept the historical uploads while they were continuing to fall behind on real-time data.  That's about the only thing I could imagine that would explain your observations.

Let's all hope that the platform migration is finally settled and we can go back to taking Weather Underground submissions for granted!

Cheers, Edouard

N4KHQ

  • Gentle Breeze
  • **
  • Posts: 92
    • KGADAHLO8
  • Station Details: iMac, Davis Vonage Pro
Re: My PWS not receiving WeatherCat FTP Data.
« Reply #6 on: February 16, 2018, 03:17:02 AM »
Thanks for the reply.