Author Topic: Problems with SOAP_server  (Read 685 times)

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Problems with SOAP_server
« on: December 18, 2017, 02:41:48 AM »
Recently, my forecast summary display has been crashing. The Detailed xml file seems to be coming in fine. I've not disable error displaying on my forecast page, but I may have to do that and some coding to explain why the generic forecasts are not available. I suppose I could even display just the detailed version. [banghead]

I'm using the stand-alone forecast php files from the Leuven template. I don't think the stand-alone forecast files are being supported any longer. The weather.gov SOAP users forums have a dead link.

I'm just wondering if others have had problems, are there any solutions or even other sources for these less detailed xml files that I might be able to use. BTW, I am using the httpS url. You can see the ugly (when the xml file is empty) forecast page at:
http://mid-southweather.com/forecast.html

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 125
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Problems with SOAP_server
« Reply #1 on: December 18, 2017, 08:29:18 AM »
  • As always support for Leuven template/scripts at: https://support.leuven-template.eu/
  • Your forecast retrieves the data from two NWS sources,
    • Point-Click part with the texts, in a state of flux since April 2017, nobody knows if and when the final version will be OK
    • Detailed forecast, available from the SOAP server, which has had some rare but irritating access errors, mostly at nighttime
  • You can always check if the problem is with your script or your area/NWS office by visiting the latest beta version of the Leuven scripts at https://www.weerstation-herent.be/saratoga/wsfct4/
The change from old to new NWS data-servers is postponed multiple times. First one April 2017, xx , xx , xx and now no new date is available anymore.

Solution: If you only want NWS forecastsBetter take a look of forecasts which use another data-source.  They change their API also once or twice a year, but that will not happen at the same time.
Use one script which uses NWS and another script for WU data (example: http://saratoga-weather.org/scripts-WUforecast.php#WUforecast)
You could integrate them in a nice iFrame and  use a switch to display only one of them. If the NWS script has a problem => use WU. And the other way around.

Current problem at  http://mid-southweather.com/forecast.html
Error message when retrieving the "point-click"  forecast: No data was retrieved for http://api.weather.gov/gridpoints/MEG/64,63/forecast

The scripts has to load 3 or 4 different  files to arrive at the forecast and weather-warnings.
The first JSON file has the link to the second and following links
1. https://api.weather.gov/points/35.07,-89.736
 
If you execute them in your browser you see the next links to access:
2. http://api.weather.gov/offices/MEG  => used for the issuing office and general info.
and the forecast link
3. http://api.weather.gov/gridpoints/MEG/64,63/forecast

The NWS server itself supplies those links with http ://
But the beta-NWS sever rejects since a few days that link with a "301 Permanently moved message"

The retrieval script has to be made aware for that. It is a minor security risk, so it is switched off by default.But this script only accepts forecast data in JSON format.

Add the following line in your script before you load my script:
Code: [Select]
$curlFollow = 1;
Wim

P.S. This is the first data set retrieved at https://api.weather.gov/points/35.07,-89.736 , it has only http links:
Code: [Select]
"properties": {
        "@id": "http://api.weather.gov/points/35.07,-89.736",
        "@type": "wx:Point",
        "cwa": "MEG",
        "forecastOffice": "http://api.weather.gov/offices/MEG",
        "gridX": 64,
        "gridY": 63,
        "forecast": "http://api.weather.gov/gridpoints/MEG/64,63/forecast",
        "forecastHourly": "http://api.weather.gov/gridpoints/MEG/64,63/forecast/hourly",
        "forecastGridData": "http://api.weather.gov/gridpoints/MEG/64,63",
        "observationStations": "http://api.weather.gov/gridpoints/MEG/64,63/stations",


Meteohub / Meteobridge with Vantage Pro2 UV Solar Soil Leaf
www.weerstation-wilsele.be   and   www.weerstation-herent.be
WeatherDisplay Cumulus Weatherlink using VVP and WeatherCat on a Mac Mini for development
www.weerstation-leuven.be

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Re: Problems with SOAP_server
« Reply #2 on: December 18, 2017, 03:08:13 PM »
Thanks, Mr. van der Kull! I suspected the 'problem' was with the nebulous change date and not your code was the cause. :)

The recent massive damaging weather along our Gulf coast and in Puerto Rico have not helped. The current political atmosphere has probably changed priorities, also.

I'll take a look at your suggested alternatives.

I've left the error display on because they usually help me see what the problem is. Recently it was the lack of correct formatting (no eof!). Other times the server times out. Lately the "MEG" file has been completely empty, at least the manually downloaded "file" had nothing in it! [rolleyes2]

The simplest 'solution' may be to simply display only the 'Detailed' version since it seems to be much less error prone. ThU32:-) In fact, I tend to view it more often than the less specific 'Forecast' version. Modifying the page should be relatively easy since your script is already creating a string indicating there is an error. [computer]

I hope your own forecast has promises of a Merry Christmas! ;D

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Re: Problems with SOAP_server
« Reply #3 on: December 21, 2017, 04:08:50 AM »
Looks like NOAA/NWS has found all the screws that fell on the floor earlier this month. Now they have things delicately balanced on the head of a pin and the 'summary' forecasts are working. Just as I was planning to take a week to modify/test/tweak/test/... the old or new code.[computer] [banghead] [rolleyes2]

Maybe they cleaned up the SOAP server! cmu:-)

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Re: Problems with SOAP_server
« Reply #4 on: December 24, 2017, 06:34:54 PM »
Forecast (Detailed) is now stuck at last week. Earlier today, the "Next update:" claimed that would be ~10:20am today. It now says: Sunday Dec 24 2017 - 2:03 pm. I assume that is local, but may be Eastern. Apparently something did update since the update time has changed. However, the "forecast" is 86% in the past, most of that is of little use... [rolleyes2]

Anyone else seeing a 'stuck' forecast from NOAA/NWS? Perhaps they are just short-staffed during the holidaze!  ???

I don't think it has anything to do with WC or the template, just wondering what's going on. Definitely work going on at the servers at NOAA. Tried a couple of other browsers, it's not a local caching problem. Other browsers are showing the same situation. Forecast now has an update time of 5:06pm today. Oh well, pending the release of WC3, it may be time to just dump the user to a NOAA/NWS page rather than imply things that aren't there any more... [rolleyes2]

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 125
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Problems with SOAP_server
« Reply #5 on: December 25, 2017, 08:18:57 AM »
. . .
Anyone else seeing a 'stuck' forecast from NOAA/NWS? Perhaps they are just short-staffed during the holidaze!  ???
. . .
This latest round of problems started first week of December: https://www.wxforum.net/index.php?topic=33332.0

So, Yes anyone IS stuck as both
1. the back-end SOAP server  is unavailable.
Code: [Select]
HTTP Error: Unsupported HTTP response status 504 Gateway Time-out (soapclient->response has contents of the response)2. The v3 point-click forecasts returns 3 days old data
Code: [Select]
Issued by: National Weather Service Norman, OK
Updated: Dec 22 3:24 am
3. but it also uses invalid http links where https is required.

The only thing which seems to be working correctly is the "old" point-click  forecasts scripts which should have been stopped working in April 2017.
I will change the current beta scripts to use the old v2 point-click forecast.

@xairbusdriver  you should install back-up sources such as WU or met.no to at least have a decent forecast, this on-off thing with NWS is going on since May this year.

Wim
Meteohub / Meteobridge with Vantage Pro2 UV Solar Soil Leaf
www.weerstation-wilsele.be   and   www.weerstation-herent.be
WeatherDisplay Cumulus Weatherlink using VVP and WeatherCat on a Mac Mini for development
www.weerstation-leuven.be

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Re: Problems with SOAP_server
« Reply #6 on: December 25, 2017, 11:46:50 PM »
Thanks Mr. van der Kuil,
I'm sure it is more frustrating for you devs than for us mere users. Alas, it is not the first time many of us have been frustrated by some government bureaucracy and probably won't be the last. But with higher officials forbidding the use of certain words in reports, it must be frustrating for the workers in many organizations as well. [banghead]

I'll look into your several suggestions for, hopefully, temporary sources for useable forecasts. [rolleyes2]

I now have two separate 'forecast' pages. When I see the erer-prone results, I'll simply swap names on the server to use one with just links to the NWS and WU pages. The same text/links are on the normal page above the error warnings. It would be better to have some error checking that would simply re-drect to the simple off-site links page, but I don't have time to figure out where that php should go. Different errors are occurring; 504 timeouts, first 100 character warnings, "CLIENT ERROR" alerts, etc. [rolleyes2] [banghead]

xairbusdriver

  • Storm
  • *****
  • Posts: 2180
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.13.4/WC 3.0
Re: Problems with SOAP_server
« Reply #7 on: January 07, 2018, 11:41:20 PM »
I decided against publicly using two separate pages, although I'll keep one for myself. I did put a couple of links that point to NWS and WU forecast pages. That alone seems to have fixed the SOAP server problems! I guess it's nice to know that the NWS is concerned about my pages... [interesting] If I'd known that would have fixed their problems, I would have done this month ago! [computer] :o Sorry guys and gals! lol(1) [rolleyes2] [banghead]