Author Topic: NWS Alerts for multiple Zones - creating cron jobs  (Read 4531 times)

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: NWS Alerts for multiple Zones - creating cron jobs
« Reply #15 on: May 03, 2015, 09:07:54 AM »
Leuven_Template version 2.6
To make life easier a script to be used by a cron job. This time without error messages as the second script needed is now also included.
The readme is in the zipped folder.

Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

xairbusdriver

  • Storm
  • *****
  • Posts: 2392
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: NWS Alerts for multiple Zones - creating cron jobs
« Reply #16 on: May 03, 2015, 09:15:15 PM »
I think my understanding of what counties are covered by which NWS 'Alerts' would have avoided most of this thread if I had seen one of the maps from <this NWS page>. I was under a erroneous impression (I think) that I needed to list any and all counties that I wanted 'alerts' for in an array.

Although I still don't see the exact words, it appears that the maps from the NWS County Warning Forecast Area maps will cover exactly the counties I want with only one 'city' named in "$myZC" array in /nws-alerts/nws-alerts-config.php. While the <NWS CWFA map> uses an ID of "MEG", I'm leaving the array set with nothing but "Memphis". They have a contact link, but I may have a difficult time explaining what I want, that would not be the first time this year, month, day [blush] [runoff] [banghead]... Now I'll have to wait for some real NWS alerts to appear...

Not so fast xABD! [lol] Thanks to the debug still being active, when I returned to my wx page I found warning. Although the file and line number pointed to a particular php file, I suspected it was actually a problem about the array thing. I edited that array to have the city name and one zone code. Uploaded, refreshed, and the error report went away. [cheer] I guess that's why there is a comment saying, "LOCATION|CODE...". You need at least one of each, minimum.
« Last Edit: December 30, 2017, 05:47:23 PM by xairbusdriver »