Author Topic: Leuven template CWOP display?  (Read 3266 times)

xairbusdriver

  • Storm
  • *****
  • Posts: 2385
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Leuven template CWOP display?
« on: April 27, 2015, 03:17:03 AM »
I'm getting successful enough to start trying some very minor modifications. :o I'm going to edit the /partners/partners.txt file to see if I can get a different page to display.

Following the almost line-by-line instructions, I  have two "Partners" image links in the "You find our weather info also at:" section of the page. They are Weather Underground and Citizen Weather Observation Program. The WU link opens a page with my data in a standard WU display. That's fine.

However, the CWOP link opens a window with a display of my registration data, APRS info, and very little actual weather info. The info comes from the 'gladstonefamily.net' server. It is useful to weather station owners, but not so much people just wanting to get current Wx and/or forecasts. I'd rather have the CWOP display that comes from 'findu' domain, assuming that is in keeping with their TOS.

I changed he following in /partners/partners.txt:
$arrPartners[$name]['href'] =
    "http://weather.gladstonefamily.net/site/".$arrPartners[$name]['id'];
to: "http://www.findu.com/cgi-bin/wxpage.cgi?call=".$arrPartners[$name]['id']."&last=12";
This 'hardwires' the last 12 hours of data on the display. Removing the ."&last=12" lets the display revert to the last 5 days version. There is actually no change in the historical time frames available, the setting simply pre-selects one of the choices available.

These edits don't change the only warning I have up to this point. That warning will be cleared, I think, in a future part of the instructions on how to assign multiple counties in the NWS weather warnings. The error reads:"nws-alerts: Checking more than four warning/county codes can delay the loading of your pages. You should use a cron job to get the data." I'm not worrying about it, right now. It can also be hidden when I change the background-color...

Question: Am I going to find that this screws up something later on in the template?

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Leuven template CWOP display?
« Reply #1 on: April 27, 2015, 08:53:08 AM »
I'm getting successful enough to start trying some very minor modifications. :o I'm going to edit the /partners/partners.txt file to see if I can get a different page to display.

Following the almost line-by-line instructions, I  have two "Partners" image links in the "You find our weather info also at:" section of the page. They are Weather Underground and Citizen Weather Observation Program. The WU link opens a page with my data in a standard WU display. That's fine.

However, the CWOP link opens a window with a display of my registration data, APRS info, and very little actual weather info. The info comes from the 'gladstonefamily.net' server. It is useful to weather station owners, but not so much people just wanting to get current Wx and/or forecasts. I'd rather have the CWOP display that comes from 'findu' domain, assuming that is in keeping with their TOS.

I changed he following in /partners/partners.txt:
$arrPartners[$name]['href'] =
    "http://weather.gladstonefamily.net/site/".$arrPartners[$name]['id'];
to: "http://www.findu.com/cgi-bin/wxpage.cgi?call=".$arrPartners[$name]['id']."&last=12";
This 'hardwires' the last 12 hours of data on the display. Removing the ."&last=12" lets the display revert to the last 5 days version. There is actually no change in the historical time frames available, the setting simply pre-selects one of the choices available.

These edits don't change the only warning I have up to this point. That warning will be cleared, I think, in a future part of the instructions on how to assign multiple counties in the NWS weather warnings. The error reads:"nws-alerts: Checking more than four warning/county codes can delay the loading of your pages. You should use a cron job to get the data." I'm not worrying about it, right now. It can also be hidden when I change the background-color...

Question: Am I going to find that this screws up something later on in the template?
Your question:   CWOP:
As I am not familiar with CWOP I can not assist you with that. This page is build as asked by users of the Template, based on what they are used to.
If you give me an URL to sites / pages how you would like to have it, I will try to add that.  But you are totally free to modify the scripts to your liking.

Your question:   NWS:  That message comes from the Curly-NWS scripts.  They warn you that you should choose:
1. To use less county/cities in the warnings
or
2: Use a cron job.  There is a readme which describes the need for cron

weather2/nws-alerts/NWS-alerts_read_me.html

My question 1: I am one of the last humans who is not a clairvoyant. So if you need support, please always supply an URL to your website.

There is no globe under your avatar, so there is no way I can check your pages (CWOP this time) with the demo site to see what you want to accomplish. Or give you a clickable link to the nws readme.  It will save both of us some time.

My question 2: Can you please post questions about the template at the WeatherCat Web Templates board? It was now posted under a board I never visited  "WeatherCat Integration"

By posting questions in "WeatherCat Templates", I am warned by the systyem automatically that there is maybe a new topic regarding the template.

Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

xairbusdriver

  • Storm
  • *****
  • Posts: 2385
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: Leuven template CWOP display?
« Reply #2 on: April 27, 2015, 03:07:18 PM »
UPDATED: This post refers to a site using a template. My current site is 90% hand-coded. The link below is valid but you won't see anything discussed in my comments there. [rolleyes2]

My apologies for posting in the wrong place. I'll gladly ask that if one of the Admins could move it to the correct place (WeatherCat Templates ?), I've done that quite often in a forum site I help with.

Only minutes later... as if the "Admin" didn't have enough to do, "he" moved this for me! Again, sorry for the extra work I've caused! You really ought to hire some help for these Forums! I'll nominate the guy who sells all those batteries! [roll] I'll even thrown in an extra 15% of my subscription fee! [tup]

Also, thanks for explaining how that one, very minor "error" text is generated. As I said, It's not a real concern for me at this point.

I am following Mr. Kull's very detailed and easy-to-read instructions as slowly as possible (I've never been known for my patience! [rolleyes2] ). More importantly, I am heeding his advice to "test, test, and then test some more" after every edit, no matter how insignificant. It's always rule #1 when writing or editing any code, in any language, even if it's just for an html page. [tup]

As for a link to my work-in-progress, I'll provide that, but be advised that it may be temporary. The page name may change and I am considering buying another domain so the data would be more logically available to those in my area or looking for wx info, in general. I find it very frustrating (as I told you, "patience" is not one of my limited number of virtues!) when I get an error page by following a link that holds the promise of information I'm searching for. Alas, the Internet is both permanent and changing, and often very quickly! With the above understanding, here is the link (as of 4/27/2015) to my slowly progressing use of Mr. Kull's template. old site link removed Please be aware that any ererz or misteaks are most likely those of the editor (ME!), not of Mr. Kull! If the "contact" link on that page is not working, just move back up the path a bit and use the "contact" page on the main site; just don't be confused about the purpose of that main site; it has absolutely nothing to do with 'weather'! :o : old site link removed <Primary site's Contact page>

BTW, I decided to make the edits and just see what would happen based on my wild assumption that I would not crash the interwebs. Not sure about your recent/local experiences, but my copy of the net survived my modifications just fine. However, there was a power-outage in my area late Friday nite! OTOH, that was well before I made the edits, so I'm fairly confident that it was merely a coincident. [goofy]

Thanks, in advance, for the help of the Admins, otherwise, I would simply end up duplicating this post/thread. [banghead] I do promise to edit this post, after the tread is moved, to halp alleviate any confusing text in it. [computer]

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Leuven template CWOP display?
« Reply #3 on: April 27, 2015, 04:56:09 PM »
For clarification about CWOP info:

The "partner-icons"  link to the admin / main   page for the station at WU, EWN, WOW and so on. Just to quickly check the situation.
At my own weather site (http://www.weerstation-wilsele.be/) the  CWOP icon links to http://weather.gladstonefamily.net/site/D8113
All other partner links work more or less the same.

Only for North american users the CWOP weather information and quality checks are a available using the menu at page:
http://www.weerstation-leuven.be/northam/index.php?p=85 
As all users outside North America do not have quality checking I can not use my own CWOP id, so I use one from another user as example on the demo site.
That page gives the quality information as asked by some users and is mostly based on the pages as used in the Saratoga Template
If there is more to display, please let me know so I can add it.

===

The CWOP ID is sometimes a puzzle.  For @xairbusdriver the CWOP ID is not EW7115  but E7115 to get the correct data.
For myself it is DW8113 but should be set to D8113 in the settings.

Not all CWOP id's have a W so it is not a thing I can do in the script, just take the W out the ID.

Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

xairbusdriver

  • Storm
  • *****
  • Posts: 2385
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: Leuven template CWOP display?
« Reply #4 on: April 27, 2015, 06:06:30 PM »
UPDATED: This post refers to a site using a template. My current site is 90% hand-coded. The link below is valid but you won't see anything discussed in my comments there. [rolleyes2]

Concerning the NWS 'error/warning': The template includes a file that explains how & why a cron job is useful: /nws-alerts/NWS-alerts_read_me.html. I'll study that later. :) Later: yuck... Yes, this certainly needs some work, I have so many counties listed (in three different States)... oh well...
Quote
For myself it is DW8113 but should be set to D8113 in the settings.

Not all CWOP id's have a W so it is not a thing I can do in the script, just take the W out the ID.
I also noticed the different CWOP ID's. Even the page that the template originally linked to had the shortened version in parentheses; dropping the "W". Since this is a NOAA project, please forgive the apparent American slant on things. [blush] We 'Yanks' too often forget there are other "Nations" on this planet! [rolleyes2] Your comment also explains another question I had and have managed to forget!  [lol]

The link on my temporary page now points to the CWOP display I thought it should. I still have the "W" in the $SITE['cwopId'] setting. Are you saying that a simple page showing a few graphs, a poorly proportioned radar image (I think it should be square [rolleyes2] ), and some choices of a few historical periods is NOT what you see, if you look at my <site>? If so, I should go back to the default template settings and simply delete the "W". :)

BTW, I now have a "globe". I didn't even know that's what that little bluish dot was! [blush] [banghead] [rolleyes2]

xairbusdriver

  • Storm
  • *****
  • Posts: 2385
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: Leuven template CWOP display?
« Reply #5 on: May 14, 2015, 10:40:27 PM »
Against the instructions by Mr. van der Kull, I left the "W" in my CWOP ID a few weeks ago. I'm not sure why, I must have seen CWOP data displaying properly... somewhere... and decided I knew best. [banghead] That usually causes me trouble when I'm disagreeing with an expert! [blush]

I had some time today and decided to try correcting a 'minor' problem in what was displaying on my site via the "Other stuff->CWOP Stats" link. The data displayed properly and there was the (often suspect?) green checkmark. However, the last row in the table was showing an "image" of some text that read "No data for 2015-May-07". Frankly, I didn't even notice that, even today, it was showing the wrong date! [rolleyes2]

The simple solution was to simply edit out the html for that whole table row. But I thought that was a little drastic. Another thought was a strategically placed piece of Duct Tape, but I couldn't find any that went well with the site's color scheme. I ended up doing the lazy thing, contacting Mr. Gladstone, interurpting his day, and asking several questions. He quickly sent me a link that showed what was suppose to be appearing in that table row: a basic graph of the data.

Examining his URL, I realized it was something I had talked with Mr. van der Kull about. It was that "W" that CWOP puts in your ID! Sure enough, editing the wsSettings.php file, just as I'd been told to (Drop the stupid "W"!) now resulted in the appropriate graphs for the four tabs on that page.

I may need to change the title of one of my threads; "I may be slow... but I'm also stubborn and stupid?"  I'll leave that as an exercise for one of the Admins... [computer]

So, once again, I thank Wim for knowing what he's talking about (in multiple languages, no less)! :) I'd also like to put in a good word of thanks for Mr. Gladstone! [removed link to the now castly photobucket.com site]
« Last Edit: December 30, 2017, 05:38:31 PM by xairbusdriver »