Author Topic: No Client Server Connections  (Read 2709 times)

Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
No Client Server Connections
« on: November 23, 2014, 04:51:54 AM »
All of a sudden tonight, I cannot connect either locally or through the Internet from the iOS app on either my phone or iPad. I have Enable WeatherCat Server turned on in Preferences and the correct ports are forwarded on the router. It has been working fine and I have not changed anything. Any ideas?
Blick


Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: No Client Server Connections
« Reply #1 on: November 23, 2014, 05:09:01 AM »
I rebooted my computer and when WeatherCat started, I got an error message. See screenshot.
Blick


Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: No Client Server Connections
« Reply #2 on: November 23, 2014, 05:38:24 AM »
The latest: I unplugged my router and let it sit for 30 seconds. Then reconnected to the mains. Then I quit WeatherCat and when I restarted it, I got a better result. See attached screenshot.
Blick


WCDev

  • WeatherCat Developer
  • Administrator
  • Storm
  • *****
  • Posts: 2768
    • CW9739
    • ISCOTLAN25
    • Trixology
  • Station Details: Main Station: Vantage Pro-2, 24hr fars, solar, soil/leaf station, extra temp stations, no U.V. WeatherLink IP.
Re: No Client Server Connections
« Reply #3 on: November 23, 2014, 11:34:58 AM »
Yes, when it boots it tries to bind to 49250, if that fails, 49251 and so on up to 49254.

Typically it won't be able to bind if that port is in use (which is why we run through 5 of them)

So is it working now?

Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: No Client Server Connections
« Reply #4 on: November 24, 2014, 02:40:49 PM »
Thanks for the explanation. Yes, restarting the router seems to have done it. Don't understand why the ports were mapped fine and then all of a sudden they were not available for binding.
Blick


Bull Winkus

  • Storm
  • *****
  • Posts: 782
    • EW0095
    • KARHORSE2
    • WU for Horseshoe Bend, Arkansas
  • Station Details: Davis Wireless Vantage Pro 2, iMac 24"
Re: No Client Server Connections
« Reply #5 on: November 24, 2014, 04:02:04 PM »
Gremlins!
Herb

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4743
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011)
Speaking of . . . . (Was: No Client Server Connections)
« Reply #6 on: November 24, 2014, 09:25:17 PM »
Howdy Herb, Blick, and WeatherCat believers in ghosts . . . . .

Gremlins!

 ;) . . . . Ya'  never know than those nasty beasties will show up do ya'

Cheers, Edouard  [cheers1]

Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: No Client Server Connections
« Reply #7 on: November 25, 2014, 12:27:42 AM »
Ha ha Herb and Edouard! Just as good an explanation as any theory I have heard.
Blick


Steve

  • Global Moderator
  • Storm
  • *****
  • Posts: 1256
    • DW8454
    • KOHAVON11
    • Avon Weather
  • Station Details: Davis Wireless VP2 Plus w/24 hr FARS, Leaf & Soil Station, 2017 27" iMac 3.8 GHz i5, 40GB RAM, Mac OS 10.12, WeatherCat
Re: No Client Server Connections
« Reply #8 on: November 25, 2014, 02:18:50 AM »
Steve - Avon, Ohio, USA


CWOP: DW8454 • WU: KOHAVON11 • AWEKAS • CoCoRaHS • Skywarn •  UK Met Office
MWWN •PWSweather • WeatherBug • WeatherCloud • Twitter • Facebook

Blicj11

  • Storm
  • *****
  • Posts: 2751
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: No Client Server Connections
« Reply #9 on: November 25, 2014, 06:24:55 AM »
Ha ha ha! No wonder my ports wouldn't bind. They were made by AMC.
Blick


elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4743
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011)
Touché!! (Was: No Client Server Connections)
« Reply #10 on: November 25, 2014, 11:27:31 PM »
Howdy Steve and WeatherCat "swashbucklers" . . . . ,

Gremlins!



Touché!! 

Cheers, Edouard  [cheers1]