Author Topic: Troubleshooting resources for Davis weather stations  (Read 4752 times)

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4499
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Mid 2009)
Troubleshooting resources for Davis weather stations
« on: October 28, 2014, 08:38:06 PM »
Dear WeatherCat Davis owners,

This thread is to list all the resources we have found helpful in taking care of our Davis Instruments weather stations.  It is sticky to make it easier to find for newcomers.

First and foremost is our troubleshooting guide on the WeatherCat Wiki (which not everyone may know about.)

http://wiki.trixology.com/index.php/Davis

It includes links to the following two resources.  The first is the obviously useful Davis Instruments weather station support page:

http://www.davisnet.com/support/weather/

This page includes links to the Davis knowledge base, downloadable documentation, software updates, hardware specifications, installation guides and much more.

The less obvious resource is the Davis Instrument channel on YouTube:

http://www.youtube.com/user/davisinstruments

Here you'll find videos on performing maintenance on your Davis equipment.

Please suggest additional resources and I'll be glad to add them!

Cheers, Edouard  [cheers1]

bcurry

  • Gentle Breeze
  • **
  • Posts: 74
    • CWOP EW 1820
    • INOVASCO73
  • Station Details: Vantage Pro 2 on 27" iMac running WeatherCat
Re: Troubleshooting resources for Davis weather stations
« Reply #1 on: May 02, 2017, 12:50:42 PM »
Hi all,
I didn't know if this is the place for this, please move if necessary...
My Davis Vantage Pro 2 was showing flaky humidity (again - I have replaced the sensor 3 years ago...), but this time the temperature was correct and well within the norms. It was pouring rain here and the Hum showed 79%, so I read the manual and adjusted (calibrated) the Hum to 95% (thus the resource is that the manual covers this!  8)
Just a question - have others had to do this?
I hope it's not another flaky Hum sensor or something, but the calibration seems, so far, to work. I had noted that MADIS had my Relative Hum/Dewpoint off a bit (two thumbs but a red check), maybe this will help?
I'm always nervous about adjusting things, but when the airport and all other stations were reading 90% or higher and mine was at 60% something definitely off...
Thanks for thoughts,
Bill


elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4499
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Mid 2009)
Dear Bill and WeatherCat troubleshooters,

My Davis Vantage Pro 2 was showing flaky humidity (again - I have replaced the sensor 3 years ago...), but this time the temperature was correct and well within the norms. It was pouring rain here and the Hum showed 79%, so I read the manual and adjusted (calibrated) the Hum to 95% (thus the resource is that the manual covers this!  8)
Just a question - have others had to do this?

I'm not aware of anyone else having to adjust the humidity setting.  Since you had trouble with humidity before, it could be a sign of a sensor going bad once more.  Keep an eye on it.  So long as the values seem reasonable - no reason to do anything else.

Cheers, Edouard

Blicj11

  • Storm
  • *****
  • Posts: 2566
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: Troubleshooting resources for Davis weather stations
« Reply #3 on: May 03, 2017, 01:30:11 AM »
Bill:

I have followed the Davis manual for calibrating internal humidity but not external. Once I set the calibration setting, I have not had to continue to adjust it.
Blick


mcrossley

  • Strong Breeze
  • ***
  • Posts: 205
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Troubleshooting resources for Davis weather stations
« Reply #4 on: May 03, 2017, 10:35:38 AM »
The Sensiron humidity sensor can be susceptible to contamination - especially as Davis chose not to protect it with a permeable membrane**, they just use a wire mesh! - this normally manifests itself as a lower than normal RH reading. I watched some of mine drift lower as the contamination gets worse.

You may be able to revive it by following the Sensiron cleaning procedure - washing it with de-ionised water and then following the reconditioning procedure***. Though I have had good results just washing a sensor, then leaving in a centrally heated room for a day.


** SHT1x does not contain a membrane at the sensor opening. However, a membrane may be added to prevent dirt and droplets from entering the housing and to protect the sensor. It will also reduce peak concentrations of chemical vapors. For optimal response times the air volume behind the membrane must be kept minimal. Sensirion recommends and supplies the SF1 filter cap for optimal IP54 protection (for higher protection – i.e. IP67 - SF1 must be sealed to the PCB with epoxy).

*** The following reconditioning procedure may bring the sensor back to calibration state:
Baking: 100 – 105°C at < 5%RH for 10h
Re-Hydration: 20 – 30°C at ~ 75%RH for 12h
Mark

bcurry

  • Gentle Breeze
  • **
  • Posts: 74
    • CWOP EW 1820
    • INOVASCO73
  • Station Details: Vantage Pro 2 on 27" iMac running WeatherCat
Re: Troubleshooting resources for Davis weather stations
« Reply #5 on: May 05, 2017, 11:39:40 PM »
Hi all,
Thanks for the help.
I calibrated the sensor for external humidity, against an airport nearby (well, 9 miles away and a bit further inland - I'm right on the coast), and for a day it looked good. Then mine stayed higher than theirs and went to 100% and stayed there on a day it should have read maybe 65%. I took the calibration off - set back to 0 (i.e. as it was) - and have left it for two days and it seems quite OK.
It is supposed to rain this weekend quite hard, so we'll see what happens. It was the initial rain, pouring rain, and a reading of 50% that had me start all this.
If it is still wonky, I may try the cleaning trick.

Bill


bcurry

  • Gentle Breeze
  • **
  • Posts: 74
    • CWOP EW 1820
    • INOVASCO73
  • Station Details: Vantage Pro 2 on 27" iMac running WeatherCat
Re: Troubleshooting resources for Davis weather stations
« Reply #6 on: May 06, 2017, 12:26:36 PM »
Update-
Pouring rain here and my humidity is showing 45%.
Time to get a new one (I see Scaled Instruments is offering the new digital sensor for $45. - that seems reasonable!), and then see if the old one can be repaired or saved.
I looked it up and had had the station up at the end of 2010, and the old Hum sensor (and temp that time) went out in 2014. It's now 2017 and the Hum is obviously flaky.
I tried the calibration, and what I noticed was it was too high when dry - which makes sense because even now, yesterday it read 76% in dry conditions, but today in a downpour it's showing mid 40's...

Thanks for all the help,
Bill


xairbusdriver

  • Storm
  • *****
  • Posts: 1837
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless w/remote wireless Anemometer Kit
Re: Troubleshooting resources for Davis weather stations
« Reply #7 on: May 06, 2017, 05:18:55 PM »
The 'cleaning' processes Mr. Crossley mentioned seem rather time consuming and possible difficult to accomplish at home. And you'd need yet another RH indicator. [lol]

I'm not sure you should expect to see very high RH values just because it is raining. Nor do I think a high rate of rain always results in a high RH. In fact, you would expect to see nearly 100% RH even without precip if you had heavy fog at the sensor.

While high RH is related to precip, the actual location of that very high RH is where the precip is forming; in the cloud. Heavy precip is often seen in thunderstorms and the temp on the ground can be considerably higher than even the base of the Cumulonimbus cloud. If the RH of the air below the cloud is low enough and the base of the cloud is quite high, it is possible that the rain will never even reach the ground (VIRGA).

While your sensor may indeed be inaccurate, I think you would need an identical or tested, calibrated sensor to compare it with. And, as far as I know (that's a huge variable!), RH can be a fairly localized measurement. I would think being close to a large body of water, especially with a shoreward wind, would have a higher RH than the opposite wind. OTOH, the RH in the middle of a large forrest will also have a higher RH than the same area covered by grasslands and certainly urban areas.

I do hope you find a way to verify the RH values in the least costly manner! ThU32:-)

mcrossley

  • Strong Breeze
  • ***
  • Posts: 205
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Troubleshooting resources for Davis weather stations
« Reply #8 on: May 06, 2017, 05:44:20 PM »
That's why I said I'd had good results just washing the sensor out and drying in centrally heated room for 24 hours. I don't have the facilities to do the documented recalibration process either.

You're right about rain, I have seen humidity as low as 85% or so when it is raining, though it is usually in the 90's here on the damp West coast of England.
Mark

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4499
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Mid 2009)
Try WXforum? (Was: Troubleshooting resources)
« Reply #9 on: May 06, 2017, 11:16:23 PM »
Dear Bill, Mark, and WeatherCat station caregivers,

Pouring rain here and my humidity is showing 45%.
Time to get a new one (I see Scaled Instruments is offering the new digital sensor for $45. - that seems reasonable!), and then see if the old one can be repaired or saved.

Sorry you are having so much trouble with this sensor.  You might try asking a question on the WXforum:

http://www.wxforum.net/

There are a lot of hard-core weather geeks on that forum and they might know something that would explain your problems with these sensors.  I don't know of anyone else having similar problems, perhaps it has something to do with your station location or the weather conditions in your area.

Best of luck with this and do let us know what you discover so we can learn as well!

Cheers, Edouard  [cheers1]

bcurry

  • Gentle Breeze
  • **
  • Posts: 74
    • CWOP EW 1820
    • INOVASCO73
  • Station Details: Vantage Pro 2 on 27" iMac running WeatherCat
Re: Troubleshooting resources for Davis weather stations
« Reply #10 on: May 08, 2017, 03:07:06 PM »
Hi all,
I tried cleaning the contacts at the ISS and then took the whole weather shield apart and looked at the T/H board and cleaned out what I could.
Still no joy - last night after the cleaning the H went to 76% which was about right according to surrounding stations, but then at 3 am in a downpour my H read 45%!
Seems to go backwards! LOL
Anyway, went on the WXForum, nice bunch and I've ordered a new sensor as it's supposed to be an upgrade anyway, and I'll wait for that to come and then do the replace and see if I can clean the old one more and get it going as a spare.
Found a T/H sensor for the VP2 for just over $50 all in, so not too bad.
Thanks again for all the help,
Bill


mcrossley

  • Strong Breeze
  • ***
  • Posts: 205
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Troubleshooting resources for Davis weather stations
« Reply #11 on: May 08, 2017, 04:16:07 PM »
Are you aware that if it is the very latest TH sensor (SHT31 based) and you have an older ISS then you will have to apply a -0.5°C (-0.9°F) correction to the temperature readings in the console?
Mark

xairbusdriver

  • Storm
  • *****
  • Posts: 1837
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless w/remote wireless Anemometer Kit
Re: Troubleshooting resources for Davis weather stations
« Reply #12 on: May 08, 2017, 05:02:16 PM »
Sorry to hear that cleaning didn't help. But I'm learning that hardware, like my body, doesn't last forever! As they say, getting old isn't for weaklings!

Quote
Seems to go backwards! LOL
Maybe you just re-installed it upside down! [banghead]

Can you share the source of the replacement? Always good to have suppliers in mind.

bcurry

  • Gentle Breeze
  • **
  • Posts: 74
    • CWOP EW 1820
    • INOVASCO73
  • Station Details: Vantage Pro 2 on 27" iMac running WeatherCat
Re: Troubleshooting resources for Davis weather stations
« Reply #13 on: May 08, 2017, 06:57:12 PM »
Hi all,
I was aware that I'll have to adjust the T readings, the information I saw said the same - .5° C that you have said, so thanks I'll remember that.
I ordered the replacement from
https://www.scaledinstruments.com
On the suggestion of the WXForum bunch.
I have already received an e-mail back that my order is being processed - so far great stuff!

Cheers,
Bill


xairbusdriver

  • Storm
  • *****
  • Posts: 1837
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless w/remote wireless Anemometer Kit
Re: Troubleshooting resources for Davis weather stations
« Reply #14 on: May 08, 2017, 10:46:19 PM »
That's a great dealer. Many compliments here. Be sure to install the new one right-side-up!