Author Topic: Lueven Template - error?  (Read 2822 times)

jhoke

  • Gentle Breeze
  • **
  • Posts: 56
  • this space for rent
    • EW5604
    • KPAALBRI11
    • Indian Mountain Lakes - Carbon County Weather
  • Station Details: Davis Vantage Pro2, MacMini (i5 2.5Ghz 4GBRam 500GB HD, 4TB attached storage), other bits coming soon (UV, etc)
Lueven Template - error?
« on: July 25, 2014, 09:58:26 PM »
I've gotten the template installed and fairly nailed down ... i'll be tweaking a bit later - but fairly happy
http://weather.hoke.org

When processing the tags for upload, I am consistently seeing this error in WC Log:
16:54:34 25-Jul-2014:  CustomWeb: Error in custom web page when parsing WINDDIRECTION:AVERAGE
 16:54:34 25-Jul-2014:  CustomWeb: Finished parsing.
 16:54:34 25-Jul-2014:  CustomWeb: Finished processing custom web pages
.

Not sure if it is an issue with the template/tag in the process file, it looks right:
"avgbearing":"STAT$WINDDIRECTION:AVERAGE$"

I am using the current release (not beta) of the WC software, and the current Lueven template

Any thoughts? Is there a way to get more detail from the log -- like the specific error being thrown?

Thanks in advance :)

-jph

WCDev

  • WeatherCat Developer
  • Administrator
  • Storm
  • *****
  • Posts: 2809
    • CW9739
    • ISCOTLAN25
    • Trixology
  • Station Details: Main Station: Vantage Pro-2, 24hr fars, solar, soil/leaf station, extra temp stations, no U.V. WeatherLink IP.
Re: Lueven Template - error?
« Reply #1 on: July 26, 2014, 08:43:07 AM »
Looks like the period specifier is missing so it doesn't know how long to calculate the average over. Have a look at page 179 in the current WeatherCat manual for more info.

jhoke

  • Gentle Breeze
  • **
  • Posts: 56
  • this space for rent
    • EW5604
    • KPAALBRI11
    • Indian Mountain Lakes - Carbon County Weather
  • Station Details: Davis Vantage Pro2, MacMini (i5 2.5Ghz 4GBRam 500GB HD, 4TB attached storage), other bits coming soon (UV, etc)
Re: Lueven Template - error?
« Reply #2 on: July 26, 2014, 11:16:04 AM »
Looks like the period specifier is missing so it doesn't know how long to calculate the average over. Have a look at page 179 in the current WeatherCat manual for more info.

Thanks... looks like the template is missing ":TODAY"

I will have to muck around with this a bit, I tried appending the period specifier and the file went sideways... probably a case of too early in the morning to be doing this with too much blood in my caffeine stream  [bed]

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Leuven Template - error?
« Reply #3 on: July 26, 2014, 04:47:14 PM »
Looks like the period specifier is missing so it doesn't know how long to calculate the average over. Have a look at page 179 in the current WeatherCat manual for more info.

Thanks... looks like the template is missing ":TODAY"

I will have to muck around with this a bit, I tried appending the period specifier and the file went sideways... probably a case of too early in the morning to be doing this with too much blood in my caffeine stream  [bed]
Change in realtimeTags.txt from
Code: [Select]
"avgbearing":"STAT$WINDDIRECTION:AVERAGE$"to this correct text
Code: [Select]
"avgbearing":"STAT$WINDDIRECTION:AVERAGE:HRS(0.17)$"
realtimeTags.txt is a 1 line text, very long, do not put any line breaks in as the json decoder will fail.

Sorry for the error,

Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

jhoke

  • Gentle Breeze
  • **
  • Posts: 56
  • this space for rent
    • EW5604
    • KPAALBRI11
    • Indian Mountain Lakes - Carbon County Weather
  • Station Details: Davis Vantage Pro2, MacMini (i5 2.5Ghz 4GBRam 500GB HD, 4TB attached storage), other bits coming soon (UV, etc)
Re: Lueven Template - error?
« Reply #4 on: July 26, 2014, 07:44:01 PM »
Great and Thanks Wim!

That worked for the gauges... but while troubleshooting the gauge issue i noticed that the wind reports at the top of the page (http://weather.hoke.org/) were not reporting either...

Good News - Syntax Error is gone and all seems to be functioning on the gauges ...

I am going to see if I narrow down the issue on the home page's top Wind metrics...

Gotta say - this is a very elegant bit of code here :) [cheers1]

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Lueven Template - error?
« Reply #5 on: July 26, 2014, 08:14:05 PM »
Great and Thanks Wim!

That worked for the gauges... but while troubleshooting the gauge issue i noticed that the wind reports at the top of the page (http://weather.hoke.org/) were not reporting either...

Good News - Syntax Error is gone and all seems to be functioning on the gauges ...

I am going to see if I narrow down the issue on the home page's top Wind metrics...

Gotta say - this is a very elegant bit of code here :) [cheers1]
This is the url of the testsite.
http://www.weerstation-leuven.be/weather2/index.php?p=10&wp=WC
The data is uploaded from WC (weathercat) at least one per 30 minutes.
If you encounter any problem: check here first.

For your startpage problems I need the file with the tags wsTagsWC.php before and after translation from the weathercat folders/website.

Thanks Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Lueven Template - error?
« Reply #6 on: July 26, 2014, 08:25:50 PM »
Great and Thanks Wim!

That worked for the gauges... but while troubleshooting the gauge issue i noticed that the wind reports at the top of the page (http://weather.hoke.org/) were not reporting either...

Good News - Syntax Error is gone and all seems to be functioning on the gauges ...

I am going to see if I narrow down the issue on the home page's top Wind metrics...

Gotta say - this is a very elegant bit of code here :) [cheers1]
Maybe this is of some help.
This are my current tag files for upload to the template test-site:
http://www.weerstation-leuven.be/weather2/index.php?p=10&wp=WC
Important. Those leuven test-site pages all use the same scripts. So check if the wp=WC tag is at the end of the URL. Otherwise you may be comparing you WeatherCat site with a demo for Meteohub or one of the other supported weatherprograms.

The North American/ Canada sites use the same weather-program data. You can switch between the weather-programs and the areas using the yellow box at the top.


If you compare my tag files form the attached zip with your versions, maybe you find the cause of the missing wind data.

Success, Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

wvdkuil

  • Strong Breeze
  • ***
  • Posts: 144
    • DW8113 (D8113)
    • IVLAAMSG47
    • Weatherstation Wilsele/Leuven/Belgium
  • Station Details: VantagePro2+ UV,Solar - Macbook/Mini
Re: Lueven Template - error?
« Reply #7 on: July 26, 2014, 08:59:33 PM »
. . . shortened . . .
i noticed that the wind reports at the top of the page (http://weather.hoke.org/) were not reporting either...
. . . shortened . . .
The error is to be caused by an unknown (at least for me) wind speed UOM (unit of measurement).
So I need the (by weathercat)  translated file to check what the UOM for wind is.
The tag is:  WINDSPEEDUNITS$
From the realtimetags.txt file for the gauges it seems to be "MPH".
And I expected "mph" or "mp/h" or any metric uom. And yes, I used the strtolower function. But at the wrong moment.

As I can not directly look into a php file on your site I hope this is the reason for the zero values and I changed the code to accept MPH also.

1. Unzip the attached file
2. backup the wsFunctions.php script on your website
3. upload the new version.

As all data is processed only once and cached for later use, the results only show after a new upload from weathercat. If you can not wait, delete the file in the weather2/cache/ folder.

Wim
Development and maintenance of Leuven-Template&Scripts  at: https://support.leuven-template.eu/
Support and demo for the PWS_Dashboard (HWS-template)  http://dashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

jhoke

  • Gentle Breeze
  • **
  • Posts: 56
  • this space for rent
    • EW5604
    • KPAALBRI11
    • Indian Mountain Lakes - Carbon County Weather
  • Station Details: Davis Vantage Pro2, MacMini (i5 2.5Ghz 4GBRam 500GB HD, 4TB attached storage), other bits coming soon (UV, etc)
Re: Lueven Template - error?
« Reply #8 on: July 26, 2014, 09:44:06 PM »
Wim

Thanks again! Looks like it is now registering properly both on the top page part/section, as well as the speed gauge is registering correctly!

I will send you copies of the files you requested when I get home (doing this in the car ... no I'm not driving ... my better half is)  [headbang] I'll be doing some Guinness quality control testing at a local pub in a few  [beer]