Author Topic: For me this is something new today. Wasn't there yesterday  (Read 745 times)

Weatheraardvark

  • Gale
  • ****
  • Posts: 291
  • Here are tornado sirens, lets go outside look
    • C0005
    • KIADESMI1
    • Des Moines Weather and Climate
  • Station Details: Davis VP2 Plus, Fars,Soil Moisture, Extra sensors
For me this is something new today. Wasn't there yesterday
« on: March 25, 2019, 06:22:09 PM »
When I opened WC,  I find this little thing.  and it's web thing.https://support.apple.com/en-us/HT208436
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp Station;Weatherlink IP;USB; MAC Mojave; Webcam;https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary

xairbusdriver

  • Storm
  • *****
  • Posts: 2341
    • EW7115 (E7115)
    • KTNGERMA20
    • Mid-South Weather
  • Station Details: Davis VP2 wireless + remote Anemometer/2014 Mac min - 10.14.4/WC 3.0.4
Re: For me this is something new today. Wasn't there yesterday
« Reply #1 on: March 25, 2019, 06:49:08 PM »
So, you are now running Mojave macOS 10.14? Unless you use very few, and even then only very new versions of an app, you will see this quite often. It is simply Apple's reminder that Mojave is the last version of the OS that will run 32 bit apps. Whatever the next OS name is, it will require 64-bit apps. I think they started issuing this alert back in macOS 10.13 High Sierra.

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 5301
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, Mac mini (2018), macOS 10.14.3, WeatherCat 3
Which version of WeatherCat? (Re: For me this is something new today.)
« Reply #2 on: March 25, 2019, 09:39:44 PM »
Dear Weatheraardvark, X-Air, and WeatherCat faithful,

When I opened WC,  I find this little thing.  and it's web thing.

Which version of WeatherCat are you running?  Only WeatherCat 3.x is a 64-bit application and ready for the next version of macOS.  Anything earlier is only a 32-bit application and won't work when Apple releases the next version of macOS.  If you haven't upgraded to WeatherCat 3, you'll need upgrade if you want to keep up with Apple. 

At least you have an option to upgrade when it comes to WeatherCat.  I have all sorts of software that I use everyday that will break when Apple imposes a strict 64-bit architecture requirement.  I'm probably dreaming, but I sure wish that Apple would back down on this one and create a 32-bit emulator so that all that old software would continue to run.  Apple has been around long enough that they should know how much our lives become entangled with the software we use - even software that is for whatever reason no longer supported.  This is another one of those transitions that will force us to lose access to part of our digital lives that would only be accessed via old 32-bit software.

Oh well, . . . . . Edouard

Randall75

  • Storm
  • *****
  • Posts: 1243
  • CWOP-CW6734 WeatherUnderground-KOHNEWAR6
    • CW6734
    • KOHNEWAR6
    • Randy's Weather On The Hill
  • Station Details: Davis Vantage Pro 2 Plus.iMac i5 OS High Sierra 10.13.6 8GB Ram, WeatherCat 3,Logitech 9000 Pro Web Cam
Re: For me this is something new today. Wasn't there yesterday
« Reply #3 on: March 25, 2019, 10:53:47 PM »
Hi WeatherCatters
 I got that same message when I upgraded to 10.13.6. but I was still running 3.0.2.
 It has to do with new operating system that Apple has put into effect.
I will be losing a lot of apps like Edouard when the next major release comes out if I upgrade which I probably won't do.


cheers



Weatheraardvark

  • Gale
  • ****
  • Posts: 291
  • Here are tornado sirens, lets go outside look
    • C0005
    • KIADESMI1
    • Des Moines Weather and Climate
  • Station Details: Davis VP2 Plus, Fars,Soil Moisture, Extra sensors
Re: For me this is something new today. Wasn't there yesterday
« Reply #4 on: March 26, 2019, 01:56:52 PM »
Hi WeatherCatters
 I got that same message when I upgraded to 10.13.6. but I was still running 3.0.2.
 It has to do with new operating system that Apple has put into effect.
I will be losing a lot of apps like Edouard when the next major release comes out if I upgrade which I probably won't do.


cheers

I would hope tha Edouard will be working on something that will be compatible between then and now.
Davis VP2 Plus; 24h  FARS; Extra Temp Humid sensor (2); Extra Temp Station (2); Soil Moisture/Temp Station;Weatherlink IP;USB; MAC Mojave; Webcam;https://www.weatherlink.com/embeddablePage/show/1c484adbfa914d1aa10a58ad53ccd563/summary

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 5301
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, Mac mini (2018), macOS 10.14.3, WeatherCat 3
Okay macOS bug. (Re: Something new today.)
« Reply #5 on: March 26, 2019, 09:36:53 PM »
Dear Randall, Weatheraardvark, and WeatherCat faithful,

I got that same message when I upgraded to 10.13.6. but I was still running 3.0.2.
 It has to do with new operating system that Apple has put into effect.

Okay, I haven't seen macOS claim that WeatherCat 3 wasn't compatible - yet!  I had no choice but to upgrade to Mojave 10.14.3.  There is 10.14.4 out.  I might have to upgrade to this one fairly quickly since it supposedly fixes a bug with 2018 Mac mini computers and some external displays.  Occasionally, my display "blanks out" for a moment and I definitely don't like it.

I will be losing a lot of apps like Edouard when the next major release comes out if I upgrade which I probably won't do.

Another way to avoid losing your old apps is to run a virtual machine using VM Fusion or Parallels and put an older version of macOS on that.  I will look into it as the upgrade issue gets nearer.  However, like you I'll definitely be slow to upgrade to the next version of macOS - if ever!

I would hope tha Edouard will be working on something that will be compatible between then and now.

I'm not the developer of WeatherCat.  That would be Stu (Stuart Ball.).  The only thing I've developed that is related to WeatherCat is this collection of AppleScripts:

http://athena.trixology.com/index.php?topic=1039.0

Unfortunately, they are currently unable to run thanks to the new Mojave security features.  I haven't been able to put much time into the problem, but I am thus far stumped.

Cheers, Edouard