Trixology

WeatherCat => WeatherCat Integration => Topic started by: N4KHQ on January 09, 2018, 01:40:39 PM

Title: Weather Underground Online settings.
Post by: N4KHQ on January 09, 2018, 01:40:39 PM
If I ever get Weather Unground Personal Weather Station working again. Should I uncheck Log historical data and log sent data?

Thanks
Title: Re: Weather Underground Online settings.
Post by: Blicj11 on January 09, 2018, 06:56:21 PM
No. Leave those checked. What that does is log your WU connection and FTP attempts so in the unlikely event that the problem is on your end, you can look in the log and see what your error messages tell you.

FYI, 25% of my WU uploads attempts in the past 24 hours have been rejected by WU for crimes against humanity (and failed FTP upload attempts), which is all on their end.
Title: Re: Weather Underground Online settings.
Post by: N4KHQ on January 09, 2018, 11:42:02 PM
Thanks, If you go to WC Preferences/Online/Weather Underground, my account is saying WU Server busy/unavailable  about 75% of the time available. It will switch to Running occasionally but doesn't last long. I think the servers overloaded to the point of now working. Do you think we will see improvement or is IBM is trying to kill the WU service.
Title: Re: Weather Underground Online settings.
Post by: Weatheraardvark on January 09, 2018, 11:48:09 PM
Suddenly I am getting that the server is busy,  I am guessing it is there problem. So wait it out and see what Friday looks like
Title: Re: Weather Underground Online settings.
Post by: Blicj11 on January 10, 2018, 12:55:45 AM
Thanks, If you go to WC Preferences/Online/Weather Underground, my account is saying WU Server busy/unavailable  about 75% of the time available. It will switch to Running occasionally but doesn't last long. I think the servers overloaded to the point of now working. Do you think we will see improvement or is IBM is trying to kill the WU service.

I see the same for my account. It is not you or WeatherCat. It is them. They have been like this for almost a month now. My guess is they fired all the competent people to save cash and are left with only the overwhelmed.
Title: Re: Weather Underground Online settings.
Post by: Weatheraardvark on January 10, 2018, 04:12:58 AM
I received this this evening from Davis.

Thanks you for your email to Support. Customers with accounts who send data to Weather Underground Personal Weather Station (PWS) from your weatherlink.com account may notice data is missing or not being sent to Weather Underground in a timely fashion. WeatherLink Software users who have installed Weather Underground’s plugin are also affected. We’ve been in contact with technical staff at The Weather Channel, who operates Weather Underground, and they’ve informed us their RapidFire servers are experiencing a temporary performance problem that should be resolved in the next couple days. When services are available again, we’ll make an attempt to back-fill missing data, but some data points may be lost. Operations staff at Davis Instruments are doing everything possible to make sure the most complete set of data is sent to Weather Underground as soon as possible.
 
We’ve made available a status page operated by Pingdom, a third party external monitoring service, that measures availability for Weather Underground’s RapidFire service.
 
http://stats.pingdom.com/zw9vxjhrr9ze/1850219 (http://stats.pingdom.com/zw9vxjhrr9ze/1850219)
 
Title: Re: Weather Underground Online settings.
Post by: xairbusdriver on January 10, 2018, 04:18:39 PM
Thanks for that link. Perhaps it should be mentioned on every thread where folks are asking about their wx data not being seen at WU. It's a good verification that the problem is rarely on our (or WC's) end.
Title: Re: Weather Underground Online settings.
Post by: The Grand Poohbah on January 10, 2018, 06:54:40 PM
This is "Wunderground" we're talking about, isn't it? Why would this be affecting some weather stations and not others?

I have had no problems in Weather Underground getting and displaying my weather station data. I use the Weather Underground "Storm" app several times a day to view their forecast model for my area. It's been working just fine for months.
Title: Re: Weather Underground Online settings.
Post by: N4KHQ on January 10, 2018, 07:28:42 PM
The Grand Poohbah, No sure I understand the question. The thread is talking Weather Underground (WC) Personal Weather Station (PWS) accepting uploaded weather data from WeatherCat (WC). The link posted above by Weatheraardvark shows that WU had been down 71% of the time the last 24 hours. The WU servers managed by the Weather Station and the servers are experiencing a temporary performance problem. I am guessing the performance problems are not seen by everyone until the server is brought down.
Title: Thanks for the WU status link (Re: Weather Underground)
Post by: elagache on January 10, 2018, 11:37:51 PM
Dear Weatheraardvark, X-Air, Grand, N4KHQ, and WeatherCat data submission junkies

We’ve made available a status page operated by Pingdom, a third party external monitoring service, that measures availability for Weather Underground’s RapidFire service.
 
http://stats.pingdom.com/zw9vxjhrr9ze/1850219 (http://stats.pingdom.com/zw9vxjhrr9ze/1850219)

Thank you very much for sharing this information!  [tup]

I'm going to add this monitoring service link to my collection of tools related to weather station performance.

Cheers, Edouard  [cheers1]
Title: Re: Weather Underground Online settings.
Post by: Blicj11 on January 11, 2018, 05:44:28 PM
Here is another link I just discovered, for a forum thread for WU API, that has an actual person from WU responding once in a while. He says all these problems are Amazon's fault, with a bad transition to using AWS cloud servers.

https://apicommunity.wunderground.com/weatherapi/topics/api-not-working-8jsfugpjga7xv?topic-reply-list[settings][page]=1#topic-reply-list
Title: Re: Weather Underground Online settings.
Post by: xairbusdriver on January 11, 2018, 07:06:19 PM
Thanks, Blick!
Title: Bad Jeff!! Bad! (Re: Weather Underground Online settings.)
Post by: elagache on January 12, 2018, 12:05:53 AM
Dear Blick, X-Air, and WeatherCat faithful,

Here is another link I just discovered, for a forum thread for WU API, that has an actual person from WU responding once in a while. He says all these problems are Amazon's fault, with a bad transition to using AWS cloud servers.

 [wink] . . . . For shame Jeff Bezos!!  After all, now that he is the richest man in the world we ought to be able to expect more from him that this! . . .  lol(1)

Cheers, Edouard  [cheers1]
Title: Re: Weather Underground Online settings.
Post by: xairbusdriver on January 12, 2018, 10:08:58 PM
You may have received an email from "The WU Team" apologizing and 'explaining' the recent problems.
Quote
...We’re happy to say the issues are now resolved and your service is fully restored...
Of note is that they admit that some software still in use dates back to 1994. [computer] I suspect absolutely know one there was around when that code was written. But I'm sure it was well documented with explanations of what each line did and why... Cobol does allow comments, right? lol(1) Maybe there are some notes written on the punch cards? [rolleyes2]
Title: Ah those memories of punched cards! (Was: Weather Underground Online settings.)
Post by: elagache on January 12, 2018, 11:40:38 PM
Dear X-Air and WeatherCat computer old-timers,

You may have received an email from "The WU Team" apologizing and 'explaining' the recent problems.
. . . .
Of note is that they admit that some software still in use dates back to 1994. [computer] I suspect absolutely know one there was around when that code was written. But I'm sure it was well documented with explanations of what each line did and why... Cobol does allow comments, right? lol(1) Maybe there are some notes written on the punch cards? [rolleyes2]

My good man, punched cards? . . . . . in 1994?  ???

I'll have you know that I was one of the last students to learn FORTRAN (version 66 mind you) on a CDC 6400 using punched cards.  The computer was housed in the basement of Evans hall which was nominally the building housing the Mathematics department at U.C. Berkeley.  I have many "fond" memories of racking by brain out trying to resolve a bug in that dungeon!  [banghead]  All this was in 1980 or 81 if I recall correctly.  Just a few years later they removed the CDC 6400 and replaced all the facilities with respectable SUN workstations.  Nonetheless still have some of my programs on punched cards to this day!

Did I mention I was a pack-rat?
. . . . (http://www.canebas.org/WeatherCat/Forum_support_documents/Custom_emoticons/packrat-emoticon.png)

Cheers, Edouard  [cheers1]
Title: Re: Weather Underground Online settings.
Post by: svEngineer on May 29, 2018, 06:53:39 AM
I am unable to get weathercat and wunderground to communicate, status is "running" but reports sent = 0  . However a newly set up weathercloud account is working fine.  has anyone else been able to solve this connection problem?
Title: Re: Weather Underground Online settings.
Post by: Blicj11 on May 29, 2018, 06:45:09 PM
svEngineer:

First, welcome to the WeatherCat Forum.

Second, it will be very helpful to the rest of us if we had enough information about your setup to comment. What version of WeatherCat are you using and what version of macOS?

Third, Wunderground is in a sad, long, downward death spiral and almost all of the recent communication problems are on their end. They are under new ownership and management and I suspect have terminated the employment of all of the people who knew what they were doing.

Fourth, having said all that, many people are reporting that communications are now much improved over a few months ago, so don't despair. Tell us what your setup is and we'll see if someone here can help you.
Title: Too complex a password? (Re: Weather Underground Online settings.)
Post by: elagache on May 29, 2018, 11:21:26 PM
Dear svEngineer, Blick, and WeatherCat troubleshooters,

Let me also welcome you the WeatherCat forum! (http://www.canebas.org/WeatherCat/Forum_support_documents/Custom_emoticons/welcome_smiley.gif)

I am unable to get weathercat and wunderground to communicate, status is "running" but reports sent = 0  . However a newly set up weathercloud account is working fine.  has anyone else been able to solve this connection problem?

Blick has given you the overview of what we need to troubleshoot your problem.  However, there is one possible cause that is relatively easy to check and fix.  As far as I know, Weather Underground still requires very simple passwords with only letters and numbers.  If you use a a more complex password, this sort of error occurs.  Could you double-check your Weather Underground password and if it is too complex, try a simpler one?

Cheers, Edouard  [cheers1]