Author Topic: Connection to MetOffice WOW page failure  (Read 416 times)

oamaru

  • Calm
  • *
  • Posts: 3
  • Station Details: TESA clone WH1080
Connection to MetOffice WOW page failure
« on: December 13, 2017, 07:41:12 AM »
I am just setting up WC to upload data to some web sites.  All works well except with my MetOffice WOW page.  When I click on "Start", there is an initial reaction sending data and it says "Waiting for response", but an error is returned after a few seconds (no error type displayed).   At the other end my WOW page says there is no data to display. 
My Console log is as follows:
Dec 13 20:43:14 Davids-iMac-HDD-Ext WeatherCat[77890]: Checking System Version is 10.7 or later...
Dec 13 20:43:14 Davids-iMac-HDD-Ext WeatherCat[77890]: System Version Check OK, running...
Dec 13 20:43:14 Davids-iMac-HDD-Ext WeatherCat[77890]: Main Controller initialised.
Dec 13 20:43:14 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCat is Running...
Dec 13 20:43:16 Davids-iMac-HDD-Ext WeatherCat[77890]: Launching WeatherCat kicker
Dec 13 20:43:16 Davids-iMac-HDD-Ext WeatherCat[77890]: DM 0: ***Hello!***
Dec 13 20:43:16 Davids-iMac-HDD-Ext WeatherCat[77890]: DM 0: Initialising sample cache
Dec 13 20:43:17 Davids-iMac-HDD-Ext WeatherCat[77890]: DM 0: Sample cache initialised. Took 1.29 seconds
Dec 13 20:43:17 Davids-iMac-HDD-Ext WeatherCat[77890]: Loading current month...



Dec 13 20:43:29 Davids-iMac-HDD-Ext WeatherCat[77890]: StatsInit took 10.857856 seconds to process
Dec 13 20:43:29 Davids-iMac-HDD-Ext WeatherCat[77890]: Stats(0) took 0.222374 seconds to parse
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/BannerGenerator.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded Banner Generator.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/CurrentConditionsCalculator.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded Current Conditions Calculator.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/MeteoTemplate.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded MeteoTemplate.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/MetOfficeWOW.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded MetOfficeWow.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/PWSWeather.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded PWSWeather.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/SQLDriver.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded SQLDriver.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/WCStatus.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded Live Data.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/WeatherBug.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded WeatherBug.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Examining /Applications/WeatherCat.app/Contents/Resources//IntegratedPlugins/WeatherCloud.bundle.
Dec 13 20:43:31 Davids-iMac-HDD-Ext WeatherCat[77890]: WeatherCatPlugInManager: Loaded WeatherCloud.
Dec 13 20:43:33 Davids-iMac-HDD-Ext WeatherCat[77890]: Error in convertFromChannelTypeToDataSel - unknown channel type
Dec 13 20:43:36 Davids-iMac-HDD-Ext WeatherCat[77890]: Trying to bind to network port
Dec 13 20:43:36 Davids-iMac-HDD-Ext WeatherCat[77890]: Got network port
Dec 13 20:43:36 Davids-iMac-HDD-Ext WeatherCat[77890]: getFTPPassword failed with code -25300
Dec 13 20:43:36 Davids-iMac-HDD-Ext WeatherCat[77890]: CustomWebGetFTPPassword failed with code -25300

Dec 13 20:43:41 Davids-iMac-HDD-Ext WeatherCat[77890]: Loading current month...

Dec 13 20:43:55 Davids-iMac-HDD-Ext WeatherCat[77890]: MetOffice:  dateutc=2017-12-13%2007%3A43%3A55&winddir=112&windspeedmph=3&windgustdir=0&windgustmph=3.1&humidity=90&dewptf=51.5&tempf=52.9&rainin=0.00&dailyrainin=0.13&baromin=29.971

Dec 13 20:44:12 Davids-iMac-HDD-Ext WeatherCat[77890]: Wunderground:  dateutc=2017-12-13+07%3A44%3A12&winddir=112&windspeedmph=5.4&windgustmph=5.4&windgustdir=0&windgustmph_10m=5.4&windgustdir_10m=0&humidity=90&indoorhumidity=66&dewptf=50.03&tempf=52.88&indoortempf=66.74&rainin=0.00&dailyrainin=0.13&baromin=29.974&softwaretype=WeatherCatV2.44B2&action=updateraw

Dec 13 20:44:46 Davids-iMac-HDD-Ext WeatherCat[77890]: MetOffice:  dateutc=2017-12-13%2007%3A44%3A46&winddir=135&windspeedmph=4&windgustdir=0&windgustmph=5.4&humidity=90&dewptf=51.5&tempf=52.9&rainin=0.00&dailyrainin=0.13&baromin=29.971


jennajon

  • Gentle Breeze
  • **
  • Posts: 34
    • FW2882
    • KMEELLSW44
  • Station Details: Davis Vantage Pro2 Plus, MAC 27 in. Retina, Solar and UV sensors
Re: Connection to MetOffice WOW page failure
« Reply #1 on: December 13, 2017, 09:32:12 AM »
HI there oamaru:

That site ID you are using for Metoffice looks really strange. Unless they have changed radically, the Site ID is usually 8 digits only.

--jenna

Jace

  • Storm
  • *****
  • Posts: 809
    • DW9675
    • ISuffolk62
    • Yoxford weather site.
  • Station Details: Davis Vantage Pro2, with Mac USB Data Logger. 2.4 GHz Intel Core 2 Duo MacBook, with 8 GB 1033 MHz DDR3 Memory, running Mac OSX Version 10.10.1 (Yosimite).
Re: Connection to MetOffice WOW page failure
« Reply #2 on: December 13, 2017, 08:54:55 PM »
I'm with Jenna on this my site ID for WOW is 8 digits only, all numbers, no characters at all.

JC

Blicj11

  • Storm
  • *****
  • Posts: 2831
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS High Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: Connection to MetOffice WOW page failure
« Reply #3 on: December 13, 2017, 11:17:30 PM »
My WOW site ID is 9 numbers. I set it up 4 years ago last month.
Blick


mcrossley

  • Strong Breeze
  • ***
  • Posts: 220
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Connection to MetOffice WOW page failure
« Reply #4 on: December 14, 2017, 11:59:42 AM »
Agreed, that looks like your "secret" 'application key' for DataPoint access, not your site ID.
Mark

oamaru

  • Calm
  • *
  • Posts: 3
  • Station Details: TESA clone WH1080
Re: Connection to MetOffice WOW page failure
« Reply #5 on: December 18, 2017, 07:40:53 PM »
Hi All.
Thanks for your input on this issue.
In my communications with Met Office, they assured me that the long site ID was correct.  For some reason it is now working.  However, the link from Weather Cat to my WOW page is definitely wrong, they say, which is why it returns an error.  I have tried another app (Weather Snoop on free trial) and its link to my WOW page works.  I think somewhere along the line MetOffice changed the link path.  I am not too concerned about this because I can go to my WOW page directly through a browser. 
Cheers

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4805
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011)
URL to station data has changed (Was: MetOffice WOW page failure)
« Reply #6 on: December 18, 2017, 10:22:58 PM »
Dear oamaru and WeatherCat data submission junkies,

However, the link from Weather Cat to my WOW page is definitely wrong, they say, which is why it returns an error. 

Yes you are correct.  The old syntax that WeatherCat tries to use looks like this:

Code: [Select]
http://wow.metoffice.gov.uk/sitehandlerservlet?requestedAction=READ&siteID=XXXXXXXX
Of course being a pack-rat about such things . . . . .

I had also added a bookmark so that I could look up my station immediately.  It not surprisingly was also broken.  The updated syntax is now like this:

Code: [Select]
http://wow.metoffice.gov.uk/observations/details?site_id=XXXXXXXX
I'm sure this will get corrected when our fearless leader gets around to it.

Cheers, Edouard  [cheers1]

Steve

  • Global Moderator
  • Storm
  • *****
  • Posts: 1263
    • DW8454
    • KOHAVON11
    • Avon Weather
  • Station Details: Davis Wireless VP2 Plus w/24 hr FARS, Leaf & Soil Station, 2017 27" iMac 3.8 GHz i5, 40GB RAM, Mac OS 10.13, WeatherCat 3
Re: Connection to MetOffice WOW page failure
« Reply #7 on: December 19, 2017, 12:33:26 AM »
I moved to a new computer, and I can't even log into WOW any more. Their new site only allows logins from social media accounts, and says it wouldn't be tied to old account statistics. And when I click on Facebook or Twitter to use those logins, nothing happens.

I guess I'm done contributing to the Met Office...
Steve - Avon, Ohio, USA


CWOP: DW8454 • WU: KOHAVON11 • AWEKAS • CoCoRaHS • Skywarn •  UK Met Office
MWWN •PWSweather • WeatherBug • WeatherCloud • Twitter • Facebook

mcrossley

  • Strong Breeze
  • ***
  • Posts: 220
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Connection to MetOffice WOW page failure
« Reply #8 on: December 19, 2017, 10:17:55 AM »
Yeah, logging in to the web interface using a met office WAVE account -the server returns an error 500 - Internal server error.
I also note that by default the login is attempted over http not https - not good Met Office :(
Mark

elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4805
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Early 2011)
Just successfully logged in. (Re: Connection to MetOffice WOW)
« Reply #9 on: December 19, 2017, 10:51:28 PM »
Dear Steve and Mark,

I just successfully logged in using my Met Office login and password.  No problems at all.  Which browsers are you guys using?  I used the latest Firefox, could there be a compatibility issue?

Cheers, Edouard

Blicj11

  • Storm
  • *****
  • Posts: 2831
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS High Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: Connection to MetOffice WOW page failure
« Reply #10 on: December 19, 2017, 11:22:22 PM »
I also logged in to my account with Safari.
Blick


mcrossley

  • Strong Breeze
  • ***
  • Posts: 220
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Connection to MetOffice WOW page failure
« Reply #11 on: December 20, 2017, 01:25:48 PM »
I was using Chrome, just tried IE 11 and it works!
Mark

Steve

  • Global Moderator
  • Storm
  • *****
  • Posts: 1263
    • DW8454
    • KOHAVON11
    • Avon Weather
  • Station Details: Davis Wireless VP2 Plus w/24 hr FARS, Leaf & Soil Station, 2017 27" iMac 3.8 GHz i5, 40GB RAM, Mac OS 10.13, WeatherCat 3
Re: Connection to MetOffice WOW page failure
« Reply #12 on: December 20, 2017, 04:34:51 PM »
Here's what I see when I try to sign in from my account page using Safari. I don't even get an option to log in with my email and password. I can't turn on the uploader because I've lost my PIN for Met Office, and can't log in to generate a new one.

Steve - Avon, Ohio, USA


CWOP: DW8454 • WU: KOHAVON11 • AWEKAS • CoCoRaHS • Skywarn •  UK Met Office
MWWN •PWSweather • WeatherBug • WeatherCloud • Twitter • Facebook

mcrossley

  • Strong Breeze
  • ***
  • Posts: 220
  • Sorry, I'm not a WeatherCat user!
    • ICHESHIR25
    • Wilmslow Astro Weather
  • Station Details: WH1090
Re: Connection to MetOffice WOW page failure
« Reply #13 on: December 20, 2017, 09:18:29 PM »
That is what I see in Chrome. The button style is set to display:none.
It does work in IE though - time to dig out a crappy old browser?
Mark

Blicj11

  • Storm
  • *****
  • Posts: 2831
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS High Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: Connection to MetOffice WOW page failure
« Reply #14 on: December 20, 2017, 09:33:32 PM »
Speaking of crappy old browsers, maybe the IT group at the MetOffice are all strictly IE fans.
Blick