Author Topic: WeatherCatPad doesn't connect to Local  (Read 789 times)

johnpolak

  • Gentle Breeze
  • **
  • Posts: 17
    • ITOMINTO2
  • Station Details: Davis Vantage Pro 2 on iMac running OSX 10.10.5
WeatherCatPad doesn't connect to Local
« on: January 27, 2016, 08:37:29 AM »
Hi All

I recently installed WeatherCatPad on my iPad - it seemed to work okay to begin with. However now, it doesn't appear to be able to find anything when set to 'local'. It just says 'searching for local' at the top. Am I missing something here? Is there something that needs to be set in preferences on the computer based Weathercat? I was sure it was connecting okay originally - and nothing has been changed since. I have tried the usual restarts etc, but no joy. Any help appreciated.

dfw_pilot

  • Gale
  • ****
  • Posts: 269
    • EW7118
    • KTXLEWIS26
    • WX Page
  • Station Details: Davis Pro2 Soil Temp/Moist
Any Updates?
« Reply #1 on: January 27, 2016, 08:47:31 AM »
Make sure your WeatherCat preferences still have Advanced->Server ticked.
Try restarting WeatherCat.
The last time my app wouldn't load data was because WeatherCat was telling me there was an update available. Unbelievably, this made it stop serving data to the iOS app. Let us know if you get it sorted out.
A clear conscience is a great pillow.


johnpolak

  • Gentle Breeze
  • **
  • Posts: 17
    • ITOMINTO2
  • Station Details: Davis Vantage Pro 2 on iMac running OSX 10.10.5
Re: WeatherCatPad doesn't connect to Local
« Reply #2 on: January 27, 2016, 05:19:49 PM »
Thanks dfw - a restart appears to have done the trick!

Blicj11

  • Storm
  • *****
  • Posts: 2566
    • EW3808
    • KUTHEBER6
    • Timber Lakes Utah
  • Station Details: Davis Vantage Pro2 Plus | WeatherLinkIP™ Data Logger | iMac (late 2013), 3.5 GHz Intel Core i7, 24 GB RAM, macOS Sierra | Sharx SCNC2900 Webcam | Supportive Wife
Re: WeatherCatPad doesn't connect to Local
« Reply #3 on: January 27, 2016, 05:23:09 PM »
Glad you are up and running.

This has happened to me several times and I have never quite got to the bottom of it. Things I have done that you can try:

  • If you have another Mac that is not your WeatherCat Mac, see if you can successfully run the Server app on it. This tells you that the server app is running correctly
  • Reboot the machine hosting WeatherCat
  • Reboot your router
Blick


elagache

  • Global Moderator
  • Storm
  • *****
  • Posts: 4499
    • DW3835
    • KCAORIND10
    • Canebas Weather
  • Station Details: Davis Vantage Pro-2, MacBook Pro (Mid 2009)
Also try iPad reset. (Re: WeatherCatPad doesn't connect to Local)
« Reply #4 on: January 27, 2016, 11:00:07 PM »
Dear John, Blick, and WeatherCat iOS fans,

I recently installed WeatherCatPad on my iPad - it seemed to work okay to begin with. However now, it doesn't appear to be able to find anything when set to 'local'.

I wasn't sure if you tried this, but did you reset your iPad? (the second instruction on this Apple support page:)

https://support.apple.com/en-us/HT201559

If you don't do a "hard restart" or reset, you don't force the iPad to reload all memory.  I've noticed a number of conditions where nothing short of a reset will due.  In particular, getting a successful sync with iTunes frequently will only happen after a reset.

Cheers, Edouard